Unsupported Device: Amazon Kindle 2013 (3rd gen.)

As of the November 2020 update to game version 55.0, the Amazon Kindle 2013 (3rd gen.) device is no longer supported and will not be able to play Animal Jam. 

The Amazon Appstore will not show that the device is not supported and will allow you to download an older version of the app. As our game runs on live servers, you will not be able to play on any outdated versions of Animal Jam. 

Don't worry though; if your account was registered then your game date, items, and purchases are saved. You will need to use a supported device to continue playing Animal Jam. 

Was this article helpful?
48 out of 85 found this helpful

If your question hasn't been answered in our help section, you can submit a request to AJ Support, and we will respond as soon as possible. Currently, support is only available in English. Submit a Request